问题描述
为什么我的 Webhooks 没有收到或者有几分钟的延迟?
可能原因
1、支付宝渠道:没有开通支付宝的查询接口或者支付宝公钥填写不正确。
2、非支付宝渠道:你的服务器响应出现问题。
解决方案
1. 支付宝渠道:
【账务明细】接口和【交易查询】接口 需要开通,如何开通参见链接。
支付宝公钥正确填写,可参照对应链接:支付宝 APP 支付,支付宝手机网站支付,支付宝当面付,支付宝电脑网站支付(原即时到账)。支付宝公钥不影响支付,但是会用在 Webhooks 回调以及在 Ping++ 平台上的订单状态更新。
2. 非支付宝渠道:
基本上是你本身接收 Webhooks 的服务器出现问题,请使用 Ping++ 管理平台 -> 点击对应的应用 -> 应用设置联调工具 -> Webhooks 通知查询工具 -> 选择查询事件、Webhooks Url、查询条件 -> 输入商户订单号或者 Ping++ 流水号 -> 点击搜索,就可以查看到你对应订单的 Webhooks 情况,包括 Ping++ 发送的时间,发送几次,发送内容以及你响应的状态码,相应的内容。