问题描述:
为什么我的 webhooks 没有收到或者有几分钟的延迟?
可能原因:
1、没有开通支付宝的查询接口或者支付宝公钥填写不正确。
2、你的服务器响应出现问题。
解决方案:
支付宝渠道请确认两点:
1、【账务明细】接口和【交易查询】接口 需要开通,如何开通参见链接。
2、支付宝公钥正确填写,可参照对应链接:支付宝 APP 支付,支付宝手机网站支付,支付宝当面付,支付宝电脑网站支付(原即时到账)
非支付宝渠道,基本上是你本身接收 webhooks 的服务器出现问题,请使用 Ping++ 管理平台->联调工具->Webhooks 查询工具,输入订单号或者 charge id 就可以查看到你对应订单的 webhooks 情况,包括 Ping++ 发送的时间,发送几次,发送内容以及你响应的状态码,相应的内容。